Help!... Part needed... Log Out | Topics | Search
Moderators | Register | Edit Profile

Alembic Club » Owning an Alembic » Troubleshooting » Help!... Part needed... « Previous Next »

Author Message
fc_spoiler
Senior Member
Username: fc_spoiler

Post Number: 1349
Registered: 5-2006
Posted on Friday, April 06, 2012 - 2:53 pm:   Edit Post

and I cant't seem to figure out what it is...

It's from a filter and I managed to break one of it's "legs" of, this is the part:


Sorry, phone pic... looks like J5n J63

I have the electronics somewhat working (in my Fender) and connected the q switch where this part came of.
I bet Mica can tell what happens when I flick the switch to the on position... It has a big red sign next to it that says: DO NOT USE!!!

If anyone can tell me what it is, I'd be very gratefull :-)
mica
Moderator
Username: mica

Post Number: 7665
Registered: 6-2000
Posted on Friday, April 06, 2012 - 7:04 pm:   Edit Post

It's a capacitor.

50nF (50 nano Farads) 63 volts.

Usually on a Q switch, we change it to an axial type instead of these cute little box ones.
fc_spoiler
Senior Member
Username: fc_spoiler

Post Number: 1350
Registered: 5-2006
Posted on Saturday, April 07, 2012 - 1:30 am:   Edit Post

Thanx! :-)

Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action:

Topics | Last Day | Last Week | Tree View | Search | Help/Instructions | Program Credits Administration