Radio signal on my alembic Log Out | Topics | Search
Moderators | Register | Edit Profile

Alembic Club » Owning an Alembic » Troubleshooting » Radio signal on my alembic « Previous Next »

Author Message
joelbanget
New
Username: joelbanget

Post Number: 3
Registered: 5-2013
Posted on Monday, June 10, 2013 - 9:48 pm:   Edit Post

if i boost lot of tone... i hear the radio on my amplifier..

how to fix it?

thx :D
stout71
Intermediate Member
Username: stout71

Post Number: 146
Registered: 7-2011
Posted on Tuesday, June 11, 2013 - 7:15 am:   Edit Post

RF interference isn't uncommon, but it is uncommon on Alembics. The shielding inside the electronics cavity is really good. Try isolating the noise by plugging into a different amp. If it goes away, it's localized to the amp, not the bass. If it's still there, check the electronics cavity of the bass and see how much shielding is in there. You may need to add some more. (Copper foil or something).
dadabass2001
Senior Member
Username: dadabass2001

Post Number: 1752
Registered: 6-2002
Posted on Tuesday, June 11, 2013 - 8:57 am:   Edit Post

Also a broken ground issue on your cable can cause RF interference as well. Try using a different lead.
Mike
jbybj
Advanced Member
Username: jbybj

Post Number: 386
Registered: 6-2006
Posted on Tuesday, June 11, 2013 - 9:05 am:   Edit Post

How old is your bass? I believe that Alembic has upgrades for older basses to specifically address RF interference. RF that wasn't an issue when the bass was first designed, but has become an issue in the new age of cellular, etc......
mario_farufyno
Senior Member
Username: mario_farufyno

Post Number: 982
Registered: 9-2008
Posted on Wednesday, June 12, 2013 - 5:45 am:   Edit Post

Joel, I live in Brazil and this is a constant issue around here. There are some areas that it doesn't bothers you, but near Radio Stations it can be really annoying. I'm writing that because saw you live in Indonesia and not every country is rigid regarding Radio and TV emissions outside US (in Brazil, we have many illegal Radio Stations that keeps invading non authorized frequencies, usually the ones I "tune" on my Rogue). Believe me, Jerry, an Alembic can be VERY sensitive to RFI depending on how laws are loose about radio transmissions.

Using some ferrite bead along PUs cable before Board (preamp) can reduce RFI a lot, but I admit that isn't enough to solve it completely. Check if you have those cylindrical magnet inside your Bass and if both cables are winded trough it. Also, if it is a Series, be sure to match gain on Dummy with the PUs properly (there are some directions on FAQ or Must Read). It is meant to kill Hum (AC induced noise), but may help on this too.

Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action:

Topics | Last Day | Last Week | Tree View | Search | Help/Instructions | Program Credits Administration