Is Alembic Telecaster Set Supposed to... Log Out | Topics | Search
Moderators | Register | Edit Profile

Alembic Club » Owning an Alembic » Troubleshooting » Archive through February 17, 2014 » Is Alembic Telecaster Set Supposed to Have a Ground? « Previous Next »

Author Message
Senior Member
Username: lbpesq

Post Number: 5497
Registered: 7-2004
Posted on Monday, July 29, 2013 - 12:22 pm:   Edit Post

I picked up a new American Standard Tele over the weekend at the Guitar Show. Really nice light weight with an ash(?) body and a tummy cut like on a Strat. Sweet guitar. I have a used set of Alembic Tele pickups I got on eBay a few years ago. I started installing them last night and realized there is no ground wire to run to under the bridge (which is standard in Teles). Is the Alembic set supposed to have a ground wire? If so, does anyone know where it is supposed to be attached?

Bill, tgo
Senior Member
Username: fc_spoiler

Post Number: 1476
Registered: 5-2006
Posted on Monday, July 29, 2013 - 12:43 pm:   Edit Post

I don't think so...
Make sure the cavity and cover is completely shielded and the housings of the pots make good contact with the shielding material (preferably conductive paint)

The new function of the shield wire hole is obvious: Weight reduction :-)
Username: mica

Post Number: 8005
Registered: 6-2000
Posted on Monday, July 29, 2013 - 4:11 pm:   Edit Post

Perfect answer, Flip!

Topics | Last Day | Last Week | Tree View | Search | Help/Instructions | Program Credits Administration