Essence low pass filter pot Log Out | Topics | Search
Moderators | Register | Edit Profile

Alembic Club » Owning an Alembic » Troubleshooting » Essence low pass filter pot « Previous Next »

Author Message
Username: lyla53

Post Number: 7
Registered: 8-2013
Posted on Friday, February 28, 2014 - 9:36 pm:   Edit Post

Just picked up a 91 Essence. A player but a very nice one. Its got a loud squeal type electronic noise (almost like speaker feed back) when I turn the low pass filter knob to the extreme bright setting. Actually it occurs just before the pot hits the mechanical limit. The squeal is momentary and silences after it passes through this position. The pot actuates smoothly with no mechanical sounds. It seems to be intermittent as well, if I turn the knob quickly I don't get the noise - slowly and I'll get it.
If it was static sounding I'd say it the pot was dirty or been set in the same position for a long time however this sound is an unusual electronic squeak or squeal. If it occurred in a live setting , it would be loud enough to clear the room
Senior Member
Username: jazzyvee

Post Number: 3885
Registered: 6-2002
Posted on Friday, February 28, 2014 - 9:56 pm:   Edit Post

Try this
Username: lyla53

Post Number: 8
Registered: 8-2013
Posted on Saturday, March 01, 2014 - 9:39 pm:   Edit Post

Thank You - I actuated the pot probably +50 times stop to stop...It helped as the noise is now intermittent however, It's there still. I can also get the noise if I tap on the pot slightly when its in the full bright position. I'm thinking I just need a new pot. Thoughts?

Add Your Message Here
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Options: Enable HTML code in message
Automatically activate URLs in message

Topics | Last Day | Last Week | Tree View | Search | Help/Instructions | Program Credits Administration