Distorted SF-2 Log Out | Topics | Search
Moderators | Register | Edit Profile

Alembic Club » Owning an Alembic » Troubleshooting » Archive through June 11, 2010 » Distorted SF-2 « Previous Next »

Author Message
Username: goose

Post Number: 3
Registered: 2-2004
Posted on Sunday, April 25, 2010 - 10:53 pm:   Edit Post

Channel B on my SF-2 produces a fuzz/fart noise and low output. Both the Direct Gain and Filter Gain are affected. Channel A seems fine. I guessing an op-amp but is there a quick way to determine which one? I have a solder gun and could probably do the repair if I know which component was the troublemaker.
Username: goose

Post Number: 4
Registered: 2-2004
Posted on Monday, April 26, 2010 - 10:10 am:   Edit Post

I tried exercising the jacks which fixes some F1X problems and hey, it seems to be the cure for the SF2 as well. Simple and effective!
Senior Member
Username: elwoodblue

Post Number: 1043
Registered: 6-2002
Posted on Monday, April 26, 2010 - 10:17 am:   Edit Post

Great news,
thanks for reporting back...if I ever hear a similar thing from my SF-2 I'll know what to try first (...and no soldering required !) :-)
Advanced Member
Username: jbybj

Post Number: 295
Registered: 6-2006
Posted on Friday, June 11, 2010 - 11:50 pm:   Edit Post

I have been experiencing intermittent crackle and cutting out with my SF-2. I just finally cured it by cleaning and exercising the ribbon cable connector inside the unit. In case this might be of some help........

Topics | Last Day | Last Week | Tree View | Search | Help/Instructions | Program Credits Administration